Help Install on Linksys E3000 with Tomato

Other OS or NAS discussions
Ianchi
Posts: 8
Joined: Mon Apr 04, 2011 5:04 am
AV Hardware: Linksys E3000

Help Install on Linksys E3000 with Tomato

Postby Ianchi » Mon Apr 04, 2011 5:49 am

Please, could you tell me which version should I install to use with this router.
I've tried the Linux mips version, but the executable exits with errors.
Then I've followed the instructions in
and installed Asus WL-HDD2.5 version.
It runs, but in ps I see a lot of instances running (see bellow).

Besides after a little while the web interface no longer works and I'm never able to actually stream to any device.

Thks!


Tomato v1.28.8501 MIPSR2_RAF E3000 USB VPN
root@unknown:/opt/twonkymediaserver# twonkymediaserver.sh start
starting twonky server
root@unknown:/opt/twonkymediaserver# TwonkyMedia Version 6.0.32

For image conversion and scaling the TMS utilizes ImageMagick. For details on th
e license please see /opt/twonkymediaserver/cgi-bin/convert-readme.txt

root@unknown:/opt/twonkymediaserver# ps
PID USER VSZ STAT COMMAND
1 root 1364 S /sbin/init noinitrd
2 root 0 SW< [kthreadd]
3 root 0 SW< [ksoftirqd/0]
4 root 0 SW< [events/0]
5 root 0 SW< [khelper]
18 root 0 SW< [kblockd/0]
45 root 0 SW [pdflush]
46 root 0 SW [pdflush]
47 root 0 SW< [kswapd0]
48 root 0 SW< [aio/0]
90 root 0 SW< [mtdblockd]
285 root 752 S hotplug2 --persistent --no-coldplug
326 root 1352 S buttons
327 root 1292 S console
328 root 1712 S /bin/sh
330 root 0 SWN [jffs2_gcd_mtd3]
332 root 1704 S syslogd -L -s 50
334 root 1700 S klogd
349 root 0 SW< [khubd]
395 root 736 S p9100d -f /dev/usb/lp0 0
430 root 0 SW< [scsi_eh_0]
431 root 0 SW< [usb-storage]
612 root 1720 S telnetd -p 23
627 root 1040 S eapd
630 root 1256 S nas
633 nobody 1036 S dnsmasq -c 1500 --log-async
641 root 2600 S httpd
643 root 1720 S crond -l 9
646 root 0 SW< [cifsoplockd]
648 root 1056 S rstats
653 root 0 SW< [cifsdnotifyd]
654 root 0 SW< [cifsd]
669 root 2508 S nmbd -D
670 root 2456 S nmbd -D
677 root 3356 S N smbd -D
737 root 1720 S -sh
1085 root 1720 S -sh
1204 root 3648 S N smbd -D
4224 root 1716 S -sh
4233 root 748 S /opt/twonkymediaserver/twonkymedia
4234 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4235 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4236 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4237 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4238 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4240 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4242 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4246 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4248 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4249 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4256 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4258 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4259 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4260 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4261 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4262 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4263 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4264 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4271 root 5380 S /opt/twonkymediaserver/twonkymediaserver
4277 root 1708 R ps

Ianchi
Posts: 8
Joined: Mon Apr 04, 2011 5:04 am
AV Hardware: Linksys E3000

Re: Help Install on Linksys E3000 with Tomato

Postby Ianchi » Mon Apr 04, 2011 6:54 pm

UPDATE

I've installed yet another version (MIPS little endian uclibc) and now it runs in only two processes (one for twonkymedia and one for twonkymediaserver) but I can't make it read the ini file, nor access the web config page.
Every time it loads it generates a new .ini file, not taking into account de default.ini.
So it always has an empty server name, and and empty httpport.
This also occurs even if I edit the .ini and set the command line parameter -inifile to it's path.

Any ideas?

Thnks


Return to “NAS and other OS”

Who is online

Users browsing this forum: No registered users and 2 guests

cron