Logging Not Working

Other OS or NAS discussions
harmonic
Posts: 1
Joined: Tue Jan 09, 2018 7:40 pm
AV Hardware: QNAP TS-869

Logging Not Working

Postby harmonic » Wed Jan 10, 2018 6:24 pm

Hi,

I initially set off to investigate/debug why some video files were being "overlooked" by Twonky media scans.

For context, I am running Twonky Server on a QNAP TS-869 Pro.
Version: Twonky Server 8.3-17
Approximately 12K video files, 0 songs, 0 photos

The first thing I noticed was that the "Enable Logging" checkbox in the web interface does not maintain state - I check it, "Save Changes" and then when I go back to "Enable Logging", it is no longer checked.
At that point, I figured the best method would be to follow the steps provided in this post by Twonky:

viewtopic.php?f=2&t=3922

After doing so, I noticed no difference in my log file - the log file retrieved from the web interface (twonkyserver-log.txt).
I then discovered that there is another log file, "twonkymediaserver-log.txt", which did have more detailed information.

I then proceeded to modify twonkyserver.ini to match the settings outlined by the Twonky post referenced above. This also had no effect.
The log file that is retrieved via the web interface only outputs a small amount of information on restart. I have confirmed that the INI file I modified is the one being used by Twonky, so I am unclear as to why the logging has not changed in any way since making the required changes/restarts.

I don't know if it is relevant, but I did have to change the location of the Twonky DB files, as it filled up my root partition on QNAP, causing it to lose RAID configuration state upon every restart of the QNAP box.

Is there anything else that can be done to enable full logging?
Is there a special setting that is overriding my INI file, or RPC changes to logging?

If I can't fix this I am going to have to move over to Plex, which would be a real disappointment for me, as I greatly prefer Twonky, but when random video files are inaccessible on my NAS, it isn't a practical long-term approach, negating the full use of my video library.

Thanks in advance for help on this.

Return to “NAS and other OS”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron