Music playback drops when using wireless/XBox/linux

Linux and UNIX specific discussions
botbanky
Posts: 7
Joined: Tue May 27, 2008 7:49 pm
AV Hardware: Dell Inspiron 6000 running Ubuntu linux, Hardy Heron 8.04 edition
XBox 360 client
DLink DI-624 wireless router

Music playback drops when using wireless/XBox/linux

Postby botbanky » Tue May 27, 2008 8:02 pm

I'm running Ubuntu Linux version Hardy Heron 8.04 with the latest patches, use a Dell Inspiron 6000 laptop, have a DLink DI-624 router with the latest firmware, an XBox 360, and downloaded the latest version of Twonky Media. TwonkyMedia on my laptop streams music to my Xbox, via a DLink router, which the XBox recognizes just fine.

However, when playing music the music playback on the 360 is frequently paused for greater than 20 seconds, and this pause/drop occurs generally once every 2 minutes. During this time, the 360 is sometimes unavailable to respond to input. This problem may be related to the fact it's a wireless connection between my computer and the 360 (through a central DLink router), because when I connect the computer via a direct ethernet cable to the 360 this problem doesn't occur. Also, my 360 interacts fine with this router, since I rarely experience any lag when playing games online. I keep my computer in my office and 360 in my family room, so a wireless setup is a must have here. Any thoughts?

HornedBeast
Posts: 33
Joined: Mon Apr 21, 2008 3:17 pm
AV Hardware: XBOX 360
Linksys Router
Linux, Ubuntu Server 8.04.

Re: Music playback drops when using wireless/XBox/linux

Postby HornedBeast » Wed May 28, 2008 3:37 pm

I still have the same problem myself. Which is odd, because videos work fine, its only music that doesn't.

I havn't tried the Beta yet, I wonder if that fixes it?

Andy

botbanky
Posts: 7
Joined: Tue May 27, 2008 7:49 pm
AV Hardware: Dell Inspiron 6000 running Ubuntu linux, Hardy Heron 8.04 edition
XBox 360 client
DLink DI-624 wireless router

Re: Music playback drops when using wireless/XBox/linux

Postby botbanky » Wed May 28, 2008 5:03 pm

I'll just echo HornedBeast's comment, in that it only happens to music and not video for me as well. So it doesn't seem like a router specific issue, but more in the communication protocol between Twonky and XBox specifically for music.

MatthewRoberts
Posts: 1
Joined: Mon Jun 09, 2008 10:45 am
AV Hardware: P4 3.2GHz, 1 Gb, 1Tb HDD, Ubuntu Hardy w/ c. 50,000 tracks MP3
Netgear MP101 (Wireless)
XBOX360 (Wired)
D-Link 520 (Wireless)
Twonky Beta 5

Re: Music playback drops when using wireless/XBox/linux

Postby MatthewRoberts » Mon Jun 09, 2008 10:53 am

I'm having the same problem, not just with the Xbox360 (wired) but also the MP101 (wireless). Running Hardy.
The Xbox also doesn't appear to handle the ID3 tags properly (the Album button is greyed out).
So, doesn't look like the problem is going away in Beta 5 :(

dbarallat
Posts: 3
Joined: Wed Jan 07, 2009 11:51 pm
AV Hardware: DNS323, DENON S31

Re: Music playback drops when using wireless/XBox/linux

Postby dbarallat » Mon Jan 12, 2009 1:12 am

My case:
- I have a 4.4.x twonky media server installed on a DNS323
- I have a Denon S31 DLNA Compatible Music Player with a wireless connection

When playing music, randomly playback drops.

I'm going to try with wired connection to check what it happens...

Dani

poppy
Posts: 3
Joined: Tue Feb 24, 2009 4:42 am
AV Hardware: Xbox 360, Linksys Router, Box running Ubuntu 8.10 w/ Twonky to share media to 360

Re: Music playback drops when using wireless/XBox/linux

Postby poppy » Tue Feb 24, 2009 5:20 am

I have the exact same problem as described by the thread starter. Linux box running Ubuntu 8.10/Twonky 5 MediaServer and an Xbox360 both connected wirelessly to a common Linksys router. Media sharing works PERFECT under Vista with this set-up.

With Twonky under Linux: 360 sees computer, connects, imports all music complete with tags sorted and looking good. Start playback and anywhere from 15-90 sec into song drops. According to 360 song is still progressing but no sound. Typically, song will continue past the end (ie. song length 3 min yet silence persists 3:30 and beyond; basically until I track forward or whatever).

Anyone else experiencing this? Frustrating to be so close and yet have a major bug.

Are the devs aware? What are they saying?

I would GLADLY pay for this ap if they would fix this. Been doing some research and feel Twonk is the best option under Linux. Tell me if I'm wrong...

streamingrookie
Posts: 2
Joined: Tue Oct 13, 2009 2:10 am
AV Hardware: Xbox360, Ubuntu/Linux laptop, Linksys wireless

Re: Music playback drops when using wireless/XBox/linux

Postby streamingrookie » Tue Oct 13, 2009 2:13 am

Has anyone discovered a fix for this? I have the exact same problem, using the trial version. I also had this problem under previous versions of Ubuntu and previous versions of TwonkyMediaServer. I hadn't used it in over 6 months, and thought I'd try it again with a clean OS load and an updated version of TMS. Still no luck. Drops out randomly. I would buy TMS if this 'bug' were fixed or if someone could tell me how to fix.

streamingrookie
Posts: 2
Joined: Tue Oct 13, 2009 2:10 am
AV Hardware: Xbox360, Ubuntu/Linux laptop, Linksys wireless

Re: Music playback drops when using wireless/XBox/linux

Postby streamingrookie » Fri Oct 16, 2009 2:21 am

FYI, found this, and it seems to work great for my xbox360 for music and pics. Haven't tried video.

code.google.com/p/ps3mediaserver/


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 2 guests

cron