Subtitles are not working on LG TV

PatZy
Posts: 2
Joined: Fri Jun 01, 2012 1:35 pm
AV Hardware: Twonky 7.0.5 Special, LG 47LK950S (TV), LG BD-650 (BluRay Player)

Subtitles are not working on LG TV

Postby PatZy » Fri Jun 01, 2012 2:01 pm

Hello,

As my Twonky 7.0.5 NAS version is not officially supported, I double-checked with the Windows version 7.0.7 of Twonky Special. The results are sadly the same:

My LG 47LK950S TV is not showing external .srt subtitles, though the subtitle is named the same way as the file (subtest.avi / subtest.srt). So I installed serviio as it says it would support subtitles with LG devices (Link: http://www.serviio.org/index.php?option ... icle&id=33 ).
And it really does, subtitles are working with serviio, as long as the playback device is set to LG. When my LG TV is set to "Generic Device", subtitles are not played in serviio, too.

So seemingly, serviio is capable of communicating with LG devices while Twonky has some problems with the way LG handles its subtitle requests? Is it possible to improve LG support with Twonky, too?

I am here to try out every idea you throw at me :)

Greetings,
PatZy
Last edited by PatZy on Fri Jun 01, 2012 3:11 pm, edited 1 time in total.

PatZy
Posts: 2
Joined: Fri Jun 01, 2012 1:35 pm
AV Hardware: Twonky 7.0.5 Special, LG 47LK950S (TV), LG BD-650 (BluRay Player)

Re: Subtitles are not working on my LG TV

Postby PatZy » Fri Jun 01, 2012 2:09 pm

P.S.: Dunno if this helps, but here is the serviio LG profile from the profiles file:

<Profile id="8" name="LG TV / player" extendsProfileId="1">
<Detection>
<HttpHeaders>
<friendlyName.dlna.org>LG.*</friendlyName.dlna.org>
</HttpHeaders>
</Detection>
<MediaFormatProfiles>
<MediaFormatProfile mime-type="video/mp4" name="">AVI</MediaFormatProfile>
</MediaFormatProfiles>
<SubtitlesMimeType>text/srt</SubtitlesMimeType>
<!--
Transcoding doesn't seem to work and some files can be played natively:
http://forum.serviio.org/viewtopic.php? ... 914#p26273
<Transcoding>
<Video targetContainer="mpegts" targetACodec="mp3">
<Matches container="matroska" aCodec="ac3" />
</Video>
</Transcoding> -->
</Profile>

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: Subtitles are not working on LG TV

Postby Twonky_Rick » Wed Jun 13, 2012 12:21 am

Thanks for sharing this. I'll pass it on and see if it helps.

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/


Return to “Internet-Ready TVs”

Who is online

Users browsing this forum: No registered users and 2 guests